åäö visas inte i .php-filerna m.m.

Frågor kring översättning av phpBB 2.0.x och dess MODdar.

Moderatorer: Supportgrupp, Moderatorgrupp, Översättningsgrupp

SilentS
Ny medlem
Ny medlem
Inlägg: 4
Blev medlem: 2006-04-26 14:28

åäö visas inte i .php-filerna m.m.

Inlägg av SilentS » 2006-04-26 14:39

Har några funderingar angående översättningarna. Jag laddade ner den svenska zip-filen från http://www.phpbb.com och installerade det i languagemappen, allt fungerade fint tills jag installerade en mod för att visa senaste aktiva ämnena och försökte ändra på den engelska texten som visas i rubriken. Då blev det scriptfel i lang_main.php. Letade upp raden och såg att det andra '-tecknet fattades (ex. $lang['All_Posts'] = 'Alla inl g;), fixade det plus några fler sådana fel och sidan fungerade igen, men nu kunde jag inte se åäö längre utan det blev helskumma tecken. Kollade i lang_main.php och där visades inga åäö utan det vara bara mellanslag där tecknet skulle vara plus att tecknet efter var försvunnet också. Ett exempel: Istället för "ämnen" stod det " nen".

Jag ser inte den minsta logik i detta. Hur kunde det överhuvudtaget fungera från början innan jag fixade '-felen? Varför slutade åäö-tecknen att visas i forumet när jag hade fixat '-felen? Varför är det bara tomt i .php-filerna där åäö ska vara? Jag har fått gå igenom allting och lägga in ö m.m. för att det ska fungera.

Jag kör Linux SuSE 10.0 (svensk översättning som inte är komplett) och har forumet på min egen Apache2-server.

Användarvisningsbild
Holger
Support
Support
Inlägg: 6485
Blev medlem: 2004-06-09 08:32
Ort: Hannover/Tyskland
Kontakt:

Inlägg av Holger » 2006-04-26 14:53

Vad använde du för editor för att korrigera filerna. Det är den som har sparat php-filerna i fel format förmodar jag.

/H
Holger Gremminger
Ingen support via PM!

Automatiserad backup av din databas med MYSQLdumper! Nu med helsvenskt gränssnitt.
Nytt: http://www.mysqldumper.se!

Hitta en expert! Registrera dig som expert!
http://www.phpbbexperts.com

caras
Aktiv medlem
Aktiv medlem
Inlägg: 142
Blev medlem: 2006-04-13 03:17

Inlägg av caras » 2006-04-26 15:11

Pröva med att öppna templates/subSilver/overall_header.tpl och mellan <head> och </head> lägger du till:
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">

Och/eller pröva att före <html> lägga till:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">

Om inget av de fungerar så är felet att du sparat tpl eller php filer i fel "character encoding"-format. I din editor (utilities >> global options..) borde inställningen vara typ ISO-8859-2...
Om du använder Notepad när du sparar php filer så borde formatet vara ANSI tror jag. Men du kan ju pröva att spara både i ANSI och UTF format och se om det fixar ditt problem

SilentS
Ny medlem
Ny medlem
Inlägg: 4
Blev medlem: 2006-04-26 14:28

Nu så

Inlägg av SilentS » 2006-04-26 17:44

Nu funkade det när jag ställde in rätt ISO-kodning i Kwrite. :) Tack för hjälpen!

Skriv svar

Vilka är online

Användare som besöker denna kategori: 1 och 0 gäst